Display Driver Crashing

Discussion in 'Technical Discussion & Support' started by Platytude, Aug 4, 2015.

  1. Platytude

    Platytude
    Expand Collapse
    New Member

    Joined:
    Aug 4, 2015
    Messages:
    3
    Likes Received:
    0
    Hi,

    I recently purchased a copy of Metro Last Light Redux on steam, and I've been having problems with the game freezing and crashing every couple of minutes. My computer specs are:

    2x GTX 570 SLI
    i5 3570k @4.2GHz
    MSI g45a gaming motherboard
    8gb ram
    Samsung 840 EVO SSD

    I'm running NVIDIA 353.62 WHQL display drivers.
    I've been looking on forums for answers for many days now, I've tried reinstalling my drivers, reinstalling the VCredist 64x, unplugging my secondary monitors, turning physX and tesselation off, and my GPU cores are staying fairly cool while I'm playing.
    Would you have any ideas how to fix this?

    Thanks
     
  2. Bamul

    Bamul
    Expand Collapse
    S.T.A.L.K.E.R.

    Joined:
    Sep 24, 2011
    Messages:
    3,865
    Likes Received:
    0
    Sorry to hear that; are you running it on Windows 10 or something else? Have you verified the local files of the game (assuming your copy uses Steam or GOG Galaxy)? You could also try running the game in safe mode since that sometimes helps stop unexplained crashes. Also, I looked this up online and it looks like many people have been experiencing similar problems back in 2014 and well into 2015 (here). Judging by the amount of players having this, and if nothing you've tried works, then it could be an issue that cannot be fixed. :(
     
    #2 Bamul, Aug 4, 2015
    Last edited by a moderator: Aug 4, 2015
  3. Platytude

    Platytude
    Expand Collapse
    New Member

    Joined:
    Aug 4, 2015
    Messages:
    3
    Likes Received:
    0
    Nope, bone stock windows 7, and I've tried verifying the game files as well. Safe mode doesn't seem to help either...
     
  4. Bamul

    Bamul
    Expand Collapse
    S.T.A.L.K.E.R.

    Joined:
    Sep 24, 2011
    Messages:
    3,865
    Likes Received:
    0
    I have no idea then. :eek:hwell: Sometimes crap like this happens with perfectly fine games - one in a series of patches breaks something unintentionally and the devs are no longer focused on fixing issues as opposed to how time they dedicate to it during post-launch periods. Maybe Komodo Saurian (a fellow moderator) will be able to help when he logs on; he has the best understanding of the Metro games from a technological point of view than probably anyone else on this forum, but like I said - it may just be be one of those problems that just can't be fixed.
     
  5. NuclearWastE3

    NuclearWastE3
    Expand Collapse
    The Toxic Avenger
    Regular

    Joined:
    Jan 4, 2013
    Messages:
    1,390
    Likes Received:
    2
    I'm not familiar with running games on SLI; but, from what I've understood, a lot of games have trouble running, correctly, on two GPUs. Perhaps turning off one of the cards could resolve your problem. Sorry that I wasn't much help.
     
    #5 NuclearWastE3, Aug 4, 2015
    Last edited by a moderator: Aug 4, 2015
  6. Platytude

    Platytude
    Expand Collapse
    New Member

    Joined:
    Aug 4, 2015
    Messages:
    3
    Likes Received:
    0
    It seems to be an SLI issue unfortunately :(
    Which sucks because my GPUs don't really pack the punch to play the game properly with just one.
    Does anyone know about a stable nvidia driver version for LL that will do SLI? Or am I SOL?
     
  7. Skaara Dreadlocks

    Skaara Dreadlocks
    Expand Collapse
    Tha Baws

    Joined:
    Sep 23, 2011
    Messages:
    3,714
    Likes Received:
    0
    Is it possible it could be a conflict between the game's sound-files and your sound-card? My friend had this problem (with an older game), and it caused his game to crash whenever he went from the menu into the actual gameplay. If he completely disabled the sound, it didn't crash. Perhpas you should quickly give that a try? If it is the reason, I know my friend knows of a quick and easy fix.

    I know it's far-fetched, but it's all I can think of :p
     
  8. Komodo Saurian

    Komodo Saurian
    Expand Collapse
    Guest

    Hey there. I used to run my copies on a single GF580, so I can give a few tips on what to do.

    You could force the game to run in DX10 to give yourself a better framerate by disabling some of the visual effects like tesselation.

    Enable "see hidden files" in the folder settings and check the ...\Users\Username\AppData\Local\4A Games\Metro Last Light\%bunch of numbers%\User.cfg file.

    Find the line "r_api" and change it from 2 to 1. You could set it to 0 to force DX9, but Redux does not officially support it and that can lead to crashing.

    You could also force windowed mode, it worked much more stable for me.
     
: crash, drivers